Bug report

posted on #1
Supporter
Posts: 2080
Joined: 30.12.10
Found a bug or got an error message?
Please give a short description, thanks!!
"Sorry - had to do it!" - Les Claypool

yes, you are looking at the administrators signature.
posted on #2
Supporter
Posts: 18
Joined: 21.02.15
Maybe this has already been mentioned, but I can't find a current thread.

I've tried to edit a song a few times, mainly the chords, or some text and I lose almost everything, although the original upload does stay in place.

I honestly prefer the old method of entering the information text, chords and the color line. I think it is much easier and foolproof.

Just my 2 cents :)
posted on #3
Supporter
Posts: 2080
Joined: 30.12.10
hmmm - "I loose almost everything" is a bit vague.
What will happen is that the old free-text chords information of tracks with lower IDs then 88.000 will be lost if you do not copy it into the supplied new markup form, which should be indicated by a pretty big warning and an option to display the old chord information to copy & paste it into the new form.
If you save your edits without doing that, shwoops, gone they are, which is indeed uncool.

If "I loose almost everything" conatains more than this issue, please do provide a bit more information on what you edited and what happened, ideally along with the track ID you worked on, and I'll have a look what the issue may be - and thanks for reporting in!
"Sorry - had to do it!" - Les Claypool

yes, you are looking at the administrators signature.
posted on #4
Supporter
Posts: 18
Joined: 21.02.15
I edited the chords, and some text in the information box. The information didn't change and I lost half of the chord information. I tried a couple times, then gave up.

I've edited before and didn't have a problem. Maybe it is because I had four lines in the chorus which I've never tried to do until now?
posted on #5
Supporter
Posts: 2080
Joined: 30.12.10
there may be 1000+n things that may have caused this, sometimes its some ' character or something I may have forgotten to encode right, I'd really need to know the ID to find out, there are just too many possibilities to be sure I've seen it all, and "real users" tend to come up with scenarios one would not think of...
"Sorry - had to do it!" - Les Claypool

yes, you are looking at the administrators signature.
posted on #6
Supporter
Posts: 48
Joined: 18.01.16
Hi Dick,
I've noticed something...
I uploaded a track to my band's page #91872 (The Strayers)
I noticed that a "non-member" "liked" my track. How come? ^^

I also noticed that when listening to a track on this band's page, there's a right sided window showing the "best liked tracks". This window shows tracks from another band.

Thanks Dick ^^
Edited by Funkystan on 08-12-2016 15:58
Funkystan
posted on #7
Supporter
Posts: 18
Joined: 21.02.15
Sorry, the track is #91948

Part of the chords are there, but I can't edit it to add the chorus, so I put them in the comments.
posted on #8
Supporter
Posts: 37
Joined: 16.07.15
Hi Dick,
I uploaded a track to my band page (track# 92144) and the following error message appear
at the bottom of the page:

Notice: Undefined variable: treejs in /www/htdocs/v130977/www/htdocs/v130977/files/backingtrack.php on line 673

The upload was successful and I see no problems other than the error message.
Thought I would let you know.
posted on #9
Supporter
Posts: 2080
Joined: 30.12.10
Psycho wrote:
Sorry, the track is #91948

Part of the chords are there, but I can't edit it to add the chorus, so I put them in the comments.


Sorry it took a bit - I just checked that track, but couldn't find any chords in the comments.
I tried to edit the track and added a little nonsense to the chordsheet which of course shall be removed, but I'll leave it in there so you can have a look, worked allright for me. You had the first two parts both named to "Verse", maybe that caused a problem, I'll re-check.
OK, 40minutes later... it's fixed, really discovered the bug you described when trying to edit my own changes and saw the second part was not imported correctly :) thx again for the hint.
"Sorry - had to do it!" - Les Claypool

yes, you are looking at the administrators signature.
posted on #10
Supporter
Posts: 2080
Joined: 30.12.10
FrankieJ wrote:
Hi Dick,
I uploaded a track to my band page (track# 92144) and the following error message appear
at the bottom of the page:

Notice: Undefined variable: ...

The upload was successful and I see no problems other than the error message.
Thought I would let you know.


thanks for the hint, fixed :)
"Sorry - had to do it!" - Les Claypool

yes, you are looking at the administrators signature.
posted on #11
Supporter
Posts: 2080
Joined: 30.12.10
Funkystan wrote:
I also noticed that when listening to a track on this band's page, there's a right sided window showing the "best liked tracks". This window shows tracks from another band.


Hey MrStan,
sorry bout the funky band behaviour there, I believe thats worked out by now as well.
I boldly gave myself access to your band to have a look at the right side panel (dun worry, speakers muted, wifes asleep) and fixed the broken avatar images there... all the tracks i saw seemed to belong to the same project, if that's not so, please point me at the track which doesn't belong.
"Sorry - had to do it!" - Les Claypool

yes, you are looking at the administrators signature.
posted on #12
Supporter
Posts: 48
Joined: 18.01.16
Hi Dick,
Fixed up! Cool to know that the boss comes around and visit us at the rehearsal room ^^

Thanks a lot Dick
Funkystan
posted on #13
Supporter
Posts: 48
Joined: 18.01.16
Hi Dick,
This litle bug comes back. Not really an issue as far as I can randomly discover great musicians albums^^
I don't know how to post a picture here and I can't find the info.
#92546 is linked to a Babbazitt album...

Thanks Dick^^
Funkystan
posted on #14
Supporter
Posts: 40
Joined: 21.06.14
Hello Dick,
The last couple of weeks I am noticing that a newly opened track is taking some time to start playing. the same issue happens on my iPhone or PC, could be the local ISP is throttling due to my heavy use of the loops or maybe a change in things on your end? sorry I am not much of a computer guy so just a guess. I was seeing some really high numbers of users, near 100 people would be on here right before I saw the "slow down", since then the numbers have dropped which makes me think it's not just in my area that it is happening. If its cost savings and a budget issue that caused a change it's not a big problem but if it's just a glitch I thought you would want to know about it.
Have a great weekend my friend
Ken
posted on #15
Supporter
Posts: 2080
Joined: 30.12.10
Thanks for the feedback, Ken, I'll have an eye on the issue.
The lower users online count is not really worrying me in any way, we've had similar waves in the previous years, I believe days getting longer and the amount of grillpartys increasing as spring rolls in in the northern hemisphere also plays a role on this ;)
We're also in need of another server upgrade quite soon, running low on storage space, and chances are things will speed up once I spread the load across another engine... I'll ask for your observation once that has been done, might be two or three more weeks untill I really have to.
"Sorry - had to do it!" - Les Claypool

yes, you are looking at the administrators signature.
posted on #16
Supporter
Posts: 32
Joined: 15.08.15
Hi Dick,
I have a similar problem to the one KMstar reported.
Songs can take longer than the actual song length before playing as well as download speeds of approximately 4-20kbs.
I have tried this on a MacBook with safari and chrome, on a Windows 10 pc with Edge and Chrome and on an iPhone with wifi and cellular.
I've also hotspotted my phone to both computers and all these combinations have the same delayed playing and slow downloads.
Hope this info is useful.
Thanks
Jeebsie
Edited by Jeebsie on 11-05-2017 14:56
posted on #17
Supporter
Posts: 2080
Joined: 30.12.10
Hey Jeebsie,
Another australian user reported similar issues, so I have this feeling it might be some intercontinental issue here.
I have set up another server instance in Melbourne, Australia yesterday which is now caching tracks down under (currently only tracks newer than ID 55.000 to be precise),
while you are still connecting to the root server in germany to request data from the database (as comments etc).
Please let me know if your issue still occurs so I can investgate further if need be.
Happy friday :)
"Sorry - had to do it!" - Les Claypool

yes, you are looking at the administrators signature.
posted on #18
Supporter
Posts: 32
Joined: 15.08.15
Hello Dick,
Thanks for fast response:)
Streaming has been good today, it looks like you've had success with the server.
Very much appreciated and have a good weekend.
Jeebsie
posted on #19
Supporter
Posts: 70
Joined: 03.05.13
Dick - not sure this is the right place for this, but I have not been able to see a way to log in on my Ipod - iOS 6.1.6. I used to be able to access my messages and feedback, but no longer. Think the ability to do so went away 6 months or so ago. Just an FYI. Cheers from here, Anne
posted on #20
Supporter
Posts: 2080
Joined: 30.12.10
Hey Anne,
In the future, best open a new thread when reporting a bug, that's a lot easier for me to keep track of :)

to be able to work out the solution, please describe the bug some more: Depending on the screen resolution of your device, you will either see the "sign in" link in the top right corner, or the three lines "buger" icon to open the mobile navigation (which includes a "sign in"-link as well - which is the case?

now, assuming you see the yellowish "sign in" link and touch that, what happens?
If the screen goes dark (thats expected), but no log in dialog is shown, please scroll up and down a little to make sure it is not accidently displayed out of your focus.

Once I know these details, I'll hopefully be able to provide a fix, until then,
you may always navigate to https://www.wikiloops.com/login.php and log in from there.
All the bestest
Richard
"Sorry - had to do it!" - Les Claypool

yes, you are looking at the administrators signature.
wikiloops online jamsessions are brought to you with friendly support by:
AnneCozean from United States

"I'm delighted to be able to support WikiLoops. It does so much for so many of us by bringing us all together and encouraging us to play nice and support each other. WikiLoops is how the World could be... thank you!"

wikiloops.com uses Cookies to provide you the best possible browsing experience.
Read more in our data privacy policy.